Command Section

EVENTHANDLER(9)        FreeBSD Kernel Developer's Manual       EVENTHANDLER(9)

NAME
     EVENTHANDLER - kernel event handling functions

SYNOPSIS
     #include <sys/eventhandler.h>

     EVENTHANDLER_DECLARE(name, type);

     EVENTHANDLER_DEFINE(name, func, arg, priority);

     EVENTHANDLER_INVOKE(name, ...);

     eventhandler_tag
     EVENTHANDLER_REGISTER(name, func, arg, priority);

     EVENTHANDLER_DEREGISTER(name, tag);

     EVENTHANDLER_DEREGISTER_NOWAIT(name, tag);

     EVENTHANDLER_LIST_DECLARE(name);

     EVENTHANDLER_LIST_DEFINE(name);

     EVENTHANDLER_DIRECT_INVOKE(name);

     eventhandler_tag
     eventhandler_register(struct eventhandler_list *list, const char *name,
         void *func, void *arg, int priority);

     void
     eventhandler_deregister(struct eventhandler_list *list,
         eventhandler_tag tag);

     void
     eventhandler_deregister_nowait(struct eventhandler_list *list,
         eventhandler_tag tag);

     struct eventhandler_list *
     eventhandler_find_list(const char *name);

     void
     eventhandler_prune_list(struct eventhandler_list *list);

DESCRIPTION
     The EVENTHANDLER mechanism provides a way for kernel subsystems to
     register interest in kernel events and have their callback functions
     invoked when these events occur.

     Callback functions are invoked in order of priority.  The relative
     priority of each callback among other callbacks associated with an event
     is given by argument priority, which is an integer ranging from
     EVENTHANDLER_PRI_FIRST (highest priority), to EVENTHANDLER_PRI_LAST
     (lowest priority).  The symbol EVENTHANDLER_PRI_ANY may be used if the
     handler does not have a specific priority associated with it.

     The normal way to use this subsystem is via the macro interface.  For
     events that are high frequency it is suggested that you additionally use
     EVENTHANDLER_LIST_DEFINE() so that the event handlers can be invoked
     directly using EVENTHANDLER_DIRECT_INVOKE() (see below).  This saves the
     invoker from having to do a locked traversal of a global list of event
     handler lists.

     EVENTHANDLER_DECLARE()
             This macro declares an event handler named by argument name with
             callback functions of type type.

     EVENTHANDLER_DEFINE()
             This macro uses SYSINIT(9) to register a callback function func
             with event handler name.  When invoked, function func will be
             invoked with argument arg as its first parameter along with any
             additional parameters passed in via macro EVENTHANDLER_INVOKE()
             (see below).

     EVENTHANDLER_REGISTER()
             This macro registers a callback function func with event handler
             name.  When invoked, function func will be invoked with argument
             arg as its first parameter along with any additional parameters
             passed in via macro EVENTHANDLER_INVOKE() (see below).  If
             registration is successful, EVENTHANDLER_REGISTER() returns a
             cookie of type eventhandler_tag.

     EVENTHANDLER_DEREGISTER()
             This macro removes a previously registered callback associated
             with tag tag from the event handler named by argument name.  It
             waits until no threads are running handlers for this event before
             returning, making it safe to unload a module immediately upon
             return from this function.

     EVENTHANDLER_DEREGISTER_NOWAIT()
             This macro removes a previously registered callback associated
             with tag tag from the event handler named by argument name.  Upon
             return, one or more threads could still be running the removed
             function(s), but no new calls will be made.  To remove a handler
             function from within that function, use this version of
             deregister, to avoid a deadlock.

     EVENTHANDLER_INVOKE()
             This macro is used to invoke all the callbacks associated with
             event handler name.  This macro is a variadic one.  Additional
             arguments to the macro after the name parameter are passed as the
             second and subsequent arguments to each registered callback
             function.

     EVENTHANDLER_LIST_DEFINE()
             This macro defines a reference to an event handler list named by
             argument name.  It uses SYSINIT(9) to initialize the reference
             and the eventhandler list.

     EVENTHANDLER_LIST_DECLARE()
             This macro declares an event handler list named by argument name.
             This is only needed for users of EVENTHANDLER_DIRECT_INVOKE()
             which are not in the same compilation unit of that list's
             definition.

     EVENTHANDLER_DIRECT_INVOKE()
             This macro invokes the event handlers registered for the list
             named by argument name.  This macro can only be used if the list
             was defined with EVENTHANDLER_LIST_DEFINE().  The macro is
             variadic with the same semantics as EVENTHANDLER_INVOKE().

     The macros are implemented using the following functions:

     eventhandler_register()
             The eventhandler_register() function is used to register a
             callback with a given event.  The arguments expected by this
             function are:

             list          A pointer to an existing event handler list, or
                           NULL.  If list is NULL, the event handler list
                           corresponding to argument name is used.

             name          The name of the event handler list.

             func          A pointer to a callback function.  Argument arg is
                           passed to the callback function func as its first
                           argument when it is invoked.

             priority      The relative priority of this callback among all
                           the callbacks registered for this event.  Valid
                           values are those in the range
                           EVENTHANDLER_PRI_FIRST to EVENTHANDLER_PRI_LAST.

             The eventhandler_register() function returns a tag that can later
             be used with eventhandler_deregister() to remove the particular
             callback function.

     eventhandler_deregister()
             The eventhandler_deregister() function removes the callback
             associated with tag tag from the event handler list pointed to by
             list.  If tag is NULL, all callback functions for the event are
             removed.  This function will not return until all threads have
             exited from the removed handler callback function(s).  This
             function is not safe to call from inside an event handler
             callback.

     eventhandler_deregister_nowait()
             The eventhandler_deregister() function removes the callback
             associated with tag tag from the event handler list pointed to by
             list.  This function is safe to call from inside an event handler
             callback.

     eventhandler_find_list()
             The eventhandler_find_list() function returns a pointer to event
             handler list structure corresponding to event name.

     eventhandler_prune_list()
             The eventhandler_prune_list() function removes all deregistered
             callbacks from the event list list.

   Kernel Event Handlers
     The following event handlers are present in the kernel:

     acpi_sleep_event
             Callbacks invoked when the system is being sent to sleep.

     acpi_wakeup_event
             Callbacks invoked when the system is being woken up.

     app_coredump_start
             Callbacks invoked at start of application core dump.

     app_coredump_progress
             Callbacks invoked during progress of application core dump.

     app_coredump_finish
             Callbacks invoked at finish of application core dump.

     app_coredump_error
             Callbacks invoked on error of application core dump.

     bpf_track
             Callbacks invoked when a BPF listener attaches to/detaches from
             network interface.

     cpufreq_levels_changed
             Callback invoked when cpu frequency levels have changed.

     cpufreq_post_change
             Callback invoked after cpu frequency has changed.

     cpufreq_pre_change
             Callback invoked before cpu frequency has changed.

     dcons_poll
             Callback invoked to poll for dcons changes.

     device_attach
             Callback invoked after a device has attached.

     device_detach
             Callbacks invoked before and after a device has detached.

     dev_clone
             Callbacks invoked when a new entry is created under /dev.

     group_attach_event
             Callback invoked when an interfance has been added to an
             interface group.

     group_change_event
             Callback invoked when an change has been made to an interface
             group.

     group_detach_event
             Callback invoked when an interfance has been removed from an
             interface group.

     ifaddr_event
             Callbacks invoked when an address is set up on a network
             interface.

     ifaddr_event_ext
             Callback invoked when an address has been added or removed from
             an interface.

     if_clone_event
             Callbacks invoked when an interface is cloned.

     iflladdr_event
             Callback invoked when an if link layer address event has
             happened.

     ifnet_arrival_event
             Callbacks invoked when a new network interface appears.

     ifnet_departure_event
             Callbacks invoked when a network interface is taken down.

     ifnet_link_event
             Callback invoked when an interfance link event has happened.

     kld_load
             Callbacks invoked after a linker file has been loaded.

     kld_unload
             Callbacks invoked after a linker file has been successfully
             unloaded.

     kld_unload_try
             Callbacks invoked before a linker file is about to be unloaded.
             These callbacks may be used to return an error and prevent the
             unload from proceeding.

     lle_event
             Callback invoked when an link layer event has happened.

     nmbclusters_change
             Callback invoked when the number of mbuf clusters has changed.

     nmbufs_change
             Callback invoked when the number of mbufs has changed.

     maxsockets_change
             Callback invoked when the maximum number of sockets has changed.

     mountroot
             Callback invoked when root has been mounted.

     power_profile_change
             Callbacks invoked when the power profile of the system changes.

     power_resume
             Callback invoked when the system has resumed.

     power_suspend
             Callback invoked just before the system is suspended.

     process_ctor
             Callback invoked when a process is created.

     process_dtor
             Callback invoked when a process is destroyed.

     process_exec
             Callbacks invoked when a process performs an exec() operation.

     process_exit
             Callbacks invoked when a process exits.

     process_fini
             Callback invoked when a process memory is destroyed.  This is
             never called.

     process_fork
             Callbacks invoked when a process forks a child.

     process_init
             Callback invoked when a process is initialized.

     random_adaptor_attach
             Callback invoked when a new random module has been loaded.

     register_framebuffer
             Callback invoked when a new frame buffer is registered.

     route_redirect_event
             Callback invoked when a route gets redirected to a new location.

     shutdown_pre_sync
             Callbacks invoked at shutdown time, before file systems are
             synchronized.

     shutdown_post_sync
             Callbacks invoked at shutdown time, after all file systems are
             synchronized.

     shutdown_final
             Callbacks invoked just before halting the system.

     tcp_offload_listen_start
             Callback invoked for TCP Offload to start listening for new
             connections.

     tcp_offload_listen_stop
             Callback invoked ror TCP Offload to stop listening for new
             connections.

     thread_ctor
             Callback invoked when a thread object is created.

     thread_dtor
             Callback invoked when a thread object is destroyed.

     thread_init
             Callback invoked when a thread object is initialized.

     thread_fini
             Callback invoked when a thread object is deinitalized.

     usb_dev_configured
             Callback invoked when a USB device is configured

     unregister_framebuffer
             Callback invoked when a frame buffer is deregistered.

     vfs_mounted
             Callback invoked when a file system is mounted.

     vfs_unmounted
             Callback invoked when a file system is unmounted.

     vlan_config
             Callback invoked when the vlan configuration has changed.

     vlan_unconfig
             Callback invoked when a vlan is destroyed.

     vm_lowmem
             Callbacks invoked when virtual memory is low.

     vxlan_start
             Callback invoked when a vxlan interface starts.

     vxlan_stop
             Callback invoked when a vxlan interface stops.

     watchdog_list
             Callbacks invoked when the system watchdog timer is
             reinitialized.

RETURN VALUES
     The macro EVENTHANDLER_REGISTER() and function eventhandler_register()
     return a cookie of type eventhandler_tag, which may be used in a
     subsequent call to EVENTHANDLER_DEREGISTER() or
     eventhandler_deregister().

     The eventhandler_find_list() function returns a pointer to an event
     handler list corresponding to parameter name, or NULL if no such list was
     found.

HISTORY
     The EVENTHANDLER facility first appeared in FreeBSD 4.0.

AUTHORS
     This manual page was written by Joseph Koshy <jkoshy@FreeBSD.org> and
     Matt Joras <mjoras@FreeBSD.org>.

FreeBSD 13.1-RELEASE-p6       September 17, 2020       FreeBSD 13.1-RELEASE-p6

Command Section

man2web Home...