Command Section

GONE_IN(9)             FreeBSD Kernel Developer's Manual            GONE_IN(9)

NAME
     gone_in, gone_in_dev - deprecation notice functions

SYNOPSIS
     #include <sys/systm.h>

     void
     gone_in(int major, const char *msg);

     void
     gone_in_dev(device_t dev, int major, const char *msg);

DESCRIPTION
     The gone_in() functions are used to provide a notice that the kernel is
     using a driver or some other functionality that is deprecated, and will
     be removed in a future FreeBSD release.  The notice is sent to the kernel
     dmesg(8) log and will appear on the console.  The major argument
     specifies the major version of the FreeBSD release that will remove the
     deprecated functionality.

     In releases before major the deprecation notice states "Deprecated code
     (to be removed in FreeBSD major): msg".  In releases equal to and after
     major the notice states "Obsolete code will be removed soon: msg".

EXAMPLES
           void
           sample_init(void)
           {
                   /* Initializaiton code omitted. */

                   gone_in(14, "Giant-locked filesystem");
           }

           int
           example_driver_attach(struct example_driver_softc *sc)
           {
                   /* Attach code omitted. */

                   gone_in_dev(sc->dev, 14, "Giant-locked driver");
           }

HISTORY
     The gone_in functions first appeared in FreeBSD 11.

FreeBSD 13.1-RELEASE-p6         August 16, 2021        FreeBSD 13.1-RELEASE-p6

Command Section

man2web Home...