Command Section

ISCSI.CONF(5)             FreeBSD File Formats Manual            ISCSI.CONF(5)

NAME
     iscsi.conf - iSCSI initiator configuration file

DESCRIPTION
     The iscsi.conf configuration file is used by the iscsictl(8) and
     iscontrol(8) utilities.  The general syntax is:

             # this is a comment
             nickname_1 {
                variable = value;
                ...
             }
             nickname_2 {
                variable = value;
                ...
             }
             ...

     AuthMethod      Sets the authentication type.  Type can be either "None",
                     or "CHAP".  Default is "None".  When set to CHAP, both
                     chapIName and chapSecret must be defined.

     chapIName       Login for CHAP authentication.

     chapSecret      Secret for CHAP authentication.

     tgtChapName     Target login for Mutual CHAP authentication.

     tgtChapSecret   Target secret for Mutual CHAP authentication.

     HeaderDigest    Sets the header digest; a checksum calculated over the
                     header of iSCSI PDUs, and verified on receive.  Digest
                     can be either "None", or "CRC32C".  Default is "None".

     DataDigest      Sets the data digest; a checksum calculated over the Data
                     Section of iSCSI PDUs, and verified on receive.  Digest
                     can be either "None", or "CRC32C".  Default is "None".

     InitiatorName   Sets the initiator name.  By default, the name is
                     concatenation of "iqn.1994-09.org.freebsd:" with the
                     hostname.

     TargetName      Sets the target name.  Not required for discovery
                     sessions.

     TargetAddress   Sets the target address and port, in address[:port]
                     format.  The address can be either an IP address, or
                     hostname.  The optional port defaults to 3260.

     SessionType     Sets the session type.  Type can be either "Discovery",
                     or "Normal".  Default is "Normal".  For normal sessions,
                     the TargetName must be defined.  Discovery sessions
                     result in the initiator connecting to all the targets
                     returned by SendTargets iSCSI discovery with the defined
                     TargetAddress.

     Enable          Enable or disable the session.  State can be either "On",
                     or "Off".  Default is "On".

     Offload         Name of selected iSCSI hardware offload driver.  Default
                     is "None".

     Protocol        Name of selected protocol.  It can be either "iSER", for
                     iSCSI over RDMA, or "iSCSI".  Default is "iSCSI".

     dscp            The DiffServ Codepoint used for sending data.  The DSCP
                     can be set to numeric, or hexadecimal values directly, as
                     well as the well-defined "cs<n>" and "af<xx>" codepoints.
                     Default is no specified dscp codepoint, which means the
                     default of the outgoing interface is used.

     pcp             The 802.1Q Priority CodePoint used for sending packets.
                     The PCP can be set to a value in the range between "0" to
                     "7".  When omitted, the default for the outgoing
                     interface is used.

FILES
     /etc/iscsi.conf

EXAMPLES
     myiscsi { # nickname
        targetaddress = iscsi1
        targetname    = iqn.1900.com.com:sn.123456
     }

     myiscsi6 { # nickname
        targetaddress = [2001:db8::de:ef]:3260
        targetname    = iqn.1900.com.com:sn.123456
     }

     chaptest {
        targetaddress = 10.0.0.1;
        targetname    = iqn.1900.com.com:sn.123456;
        initiatorname = iqn.2005-01.il.ac.huji.cs:nobody;
        authmethod    = CHAP;
        chapiname     = iqn.2005-01.il.ac.huji.cs:nobody;
        chapsecret    = "secretsecret";
     }

SEE ALSO
     iscontrol(8), iscsictl(8)

FreeBSD 13.1-RELEASE-p6           May 6, 2016          FreeBSD 13.1-RELEASE-p6

Command Section

man2web Home...