Command Section

LTC430X(4)             FreeBSD Kernel Interfaces Manual             LTC430X(4)

NAME
     ltc430x - driver for LTC4305 and LTC4306 I2C mux chips

SYNOPSIS
     To compile this driver into the kernel, place the following line in your
     kernel configuration file:

           device ltc430x

     Alternatively, to load the driver as a module at boot time, place the
     following line in loader.conf(5):

           ltc430x_load="YES"

DESCRIPTION
     The ltc430x driver supports the LTC4305 and LTC4306 I2C bus multiplexer
     (mux) chips.  It automatically connects an upstream I2C bus to one of
     several downstream buses as needed when slave devices on the downstream
     buses initiate I/O.  More information on the automatic switching behavior
     is available in iicmux(4).

FDT CONFIGURATION
     On an fdt(4) based system, an ltc430x device node is defined as a child
     node of its upstream i2c bus.  The children of the ltc430x node are
     additional i2c buses, which will have their own i2c slave devices
     described in their child nodes.

     The ltc430x driver conforms to the standard i2c/i2c-mux-ltc4306.txt
     bindings document, except that the following optional properties are not
     currently supported and will be ignored if present:
              enable-gpios
              gpio-controller
              #gpio-cells
              ltc,downstream-accelerators-enable
              ltc,upstream-accelerators-enable

     In addition, the following additional property is supported:

           freebsd,ctlreg2
                   A value to store into the chip's control register 2 during
                   initialization.  Consult the chip datasheet for the meaning
                   of the various bits in the register.

HINTS CONFIGURATION
     On a device.hints(5) based system, the following hints are required:

           hint.ltc430x.<unit>.at
                   The upstream iicbus(4) the ltc430x instance is attached to.

           hint.ltc430x.<unit>.addr
                   The slave address of the ltc430x instance on the upstream
                   bus.

           hint.ltc430x.<unit>.chip_type
                   The type of chip the driver is controlling.  Valid values
                   are "ltc4305" and "ltc4306".

     The following hints are optional:

           hint.ltc430x.<unit>.ctlreg2
                   A value to store into the chip's control register 2 during
                   initialization.  Consult the chip datasheet for the meaning
                   of the various bits in the register.  This hint is
                   optional; when missing, the driver does not update control
                   register 2.

           hint.ltc430x.<unit>.idle_disconnect
                   Whether to disconnect all downstream busses from the
                   upstream bus when idle.  If set to zero, the most recently
                   used downstream bus is left connected to the upstream bus
                   after IO completes.  Any non-zero value causes all
                   downstream busses to be disconnected when idle.  This hint
                   is optional; when missing, the driver behaves as if it were
                   zero.

     When configured via hints, the driver automatically adds an iicbus
     instance for every downstream bus supported by the chip.  There is
     currently no way to indicate used versus unused downstream channels.

SEE ALSO
     iicbus(4), iicmux(4),

HISTORY
     The ltc430x driver first appeared in FreeBSD 13.0.

FreeBSD 13.1-RELEASE-p6        September 2, 2020       FreeBSD 13.1-RELEASE-p6

Command Section

man2web Home...