Command Section

NG_BLUETOOTH(4)        FreeBSD Kernel Interfaces Manual        NG_BLUETOOTH(4)

NAME
     ng_bluetooth - placeholder for global Bluetooth variables

SYNOPSIS
     #include <sys/types.h>
     #include <netgraph/bluetooth/include/ng_bluetooth.h>

DESCRIPTION
     The ng_bluetooth module is a placeholder for global Bluetooth variables.
     All Bluetooth variables can be examined and changed via sysctl(8).

   Bluetooth Variables
     Below is the description of default variables.  Each Bluetooth module
     might add its own variables to the tree.

     net.bluetooth.version
          A read-only integer variable that shows the current version of the
          Bluetooth stack.

     net.bluetooth.hci.command_timeout
          A read-write integer variable that controls the Host Controller
          Interface (HCI) command timeout (in seconds), i.e., how long the HCI
          layer will wait for the Command_Complete or Command_Status event
          from a Bluetooth device.

     net.bluetooth.hci.connection_timeout
          A read-write integer variable that controls the HCI connection
          timeout, i.e. how long the HCI layer will wait for the
          Connection_Complete event.  Normally this should not be required as
          Bluetooth devices have connection timeout of their own and will send
          event back.  This timeout is required to ensure that no connection
          will stall in case when the HCI transport layer is broken.  Be
          careful when changing this variable.  Make sure you understand what
          you are doing.

     net.bluetooth.hci.max_neighbor_age
          A read-write integer variable that controls time-to-live (in
          seconds) for entries in the HCI neighbor cache.  Every time a
          Bluetooth device performs an Inquiry operation, the results will be
          put in cache.  Later when a Bluetooth device establishes a baseband
          connection, it will try to find the matching entry in the cache and
          use it.  This might speed up establishment of the baseband
          connection.

     net.bluetooth.l2cap.rtx_timeout
          A read-write integer variable that controls the Link Layer Control
          and Adaptation Protocol (L2CAP) Retransmission Timeout (RTX) (in
          seconds).  Every time the L2CAP layer submits a control command, the
          RTX timeout is set.  The value of the RTX timeout should be greater
          or equal to the value of the HCI connection timeout.  Be careful
          when changing this variable.  Make sure you understand what you are
          doing.

     net.bluetooth.l2cap.ertx_timeout
          A read-write integer variable that controls the L2CAP Extended
          Retransmission Timeout (ERTX) (in seconds).  In some cases remote
          peer may respond with PENDING status to the L2CAP control command.
          In this case the L2CAP command timeout is reset to the ERTX timeout
          value.  The value of the ERTX timeout should be greater or equal to
          the value of the RTX timeout.  Be careful when changing this
          variable.  Make sure you understand what you are doing.

SEE ALSO
     ng_btsocket(4), ng_hci(4), ng_l2cap(4), sysctl(8)

HISTORY
     The ng_bluetooth module was implemented in FreeBSD 5.0.

AUTHORS
     Maksim Yevmenkin <m_evmenkin@yahoo.com>

FreeBSD 13.1-RELEASE-p6        November 9, 2002        FreeBSD 13.1-RELEASE-p6

Command Section

man2web Home...