Command Section

OPERATOR(7)        FreeBSD Miscellaneous Information Manual        OPERATOR(7)

NAME
     operator - C and C++ operator precedence and order of evaluation

DESCRIPTION
           Operator                                    Associativity
           --------                                    -------------
           () [] -> .                                  left to right
           ! ~ ++ -- - (type) * & sizeof new delete    right to left
           ->* .*                                      left to right
           * / %                                       left to right
           + -                                         left to right
           << >>                                       left to right
           < <= > >=                                   left to right
           == !=                                       left to right
           &                                           left to right
           ^                                           left to right
           |                                           left to right
           &&                                          left to right
           ||                                          left to right
           ?:                                          right to left
           = += -= *= /= %= <<= >>= &= ^= |= throw     right to left
           ?: (C++, third operand)                     right to left
           ,                                           left to right

FILES
     /usr/share/misc/operator

FreeBSD 13.1-RELEASE-p6          April 8, 2009         FreeBSD 13.1-RELEASE-p6

Command Section

man2web Home...