Command Section

VM_PAGE_ALLOC(9)       FreeBSD Kernel Developer's Manual      VM_PAGE_ALLOC(9)

NAME
     vm_page_alloc - allocate a page for a vm_object

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     vm_page_t
     vm_page_alloc(vm_object_t object, vm_pindex_t pindex, int req);

DESCRIPTION
     The vm_page_alloc() function allocates a page at pindex within object.
     It is assumed that a page has not already been allocated at pindex.  The
     page returned is inserted into the object, unless VM_ALLOC_NOOBJ is
     specified in the req.

     vm_page_alloc() will not sleep.

     Its arguments are:

     object      The VM object to allocate the page for.  The object must be
                 locked if VM_ALLOC_NOOBJ is not specified.

     pindex      The index into the object at which the page should be
                 inserted.

     req         The bitwise-inclusive OR of a class and any optional flags
                 indicating how the page should be allocated.

                 Exactly one of the following classes must be specified:

                 VM_ALLOC_NORMAL         The page should be allocated with no
                                         special treatment.

                 VM_ALLOC_SYSTEM         The page can be allocated if the
                                         cache is empty and the free page
                                         count is above the interrupt reserved
                                         water mark.  This flag should be used
                                         only when the system really needs the
                                         page.

                 VM_ALLOC_INTERRUPT      vm_page_alloc() is being called
                                         during an interrupt.  A page will be
                                         returned successfully if the free
                                         page count is greater than zero.

                 The optional flags are:

                 VM_ALLOC_NOBUSY      The returned page will not be exclusive
                                      busy.

                 VM_ALLOC_NODUMP      The returned page will not be included
                                      in any kernel core dumps regardless of
                                      whether or not it is mapped in to KVA.

                 VM_ALLOC_NOOBJ       Do not associate the allocated page with
                                      a vm object.  The object argument is
                                      ignored.

                 VM_ALLOC_SBUSY       The returned page will be shared busy.

                 VM_ALLOC_WIRED       The returned page will be wired.

                 VM_ALLOC_ZERO        Indicate a preference for a pre-zeroed
                                      page.  There is no guarantee that the
                                      returned page will be zeroed, but it
                                      will have the PG_ZERO flag set if it is
                                      zeroed.

RETURN VALUES
     The vm_page_t that was allocated is returned if successful; otherwise,
     NULL is returned.

NOTES
     The pager process is always upgraded to VM_ALLOC_SYSTEM unless
     VM_ALLOC_INTERRUPT is set.

AUTHORS
     This manual page was written by Chad David <davidc@acns.ab.ca>.

FreeBSD 13.1-RELEASE-p6        November 16, 2016       FreeBSD 13.1-RELEASE-p6

Command Section

man2web Home...