prtstmf not working for me

Other open source tools published on ScottKlement.com
Post Reply
mmanske
Posts: 1
Joined: Wed Nov 22, 2023 2:55 pm

prtstmf not working for me

Post by mmanske »

having trouble getting this to work. we have like 100 printers that print pdf just fine from Acom software, that I an even use
a pc program called pdfing to view those pdf files off the outq.
when I run this - creates the file in the outq just fine - but the printer does nothing when we release it.
I checked pdfing... I get an error when attempting to open it.. unknow data stream type from lpr.
even using client access working with spool files interface, it errors out on these.
I tried the ovrprtf to use same ccsid as ones that work, that did not help

Any ideas what else to check?
I have tried two different types of PDF files off the ifs (one is an Oracle check, one is a scanned doc saved as pdf from a pc)
both are small - 66kb and 400kb
Scott Klement
Site Admin
Posts: 648
Joined: Sun Jul 04, 2021 5:12 am

Re: prtstmf not working for me

Post by Scott Klement »

PRTSTMF simply takes a stream file and copies it, byte-for-byte, to a spooled file. It is not PDF software like Acom or pdfing.

PDF software understands PDF files, and is capable of rendering them in the printer's language. PRTSTMF does not do that. It just reads the bytes and copies them straight to the spooled file (which in turn is copied to the printer.)

If your printer has built-in support for understanding PDFs, you may be able to use PRTSTMF to print a PDF. If not, you'll need software like Acom, GhostScript, Acrobat, etc that understands the PDF and converts it to the printer's language.
Post Reply