V7R5 & Ruby

Any IBM i topic that does not fit in another forum
Post Reply
mattroessner
Posts: 1
Joined: Wed Jan 03, 2024 4:09 pm

V7R5 & Ruby

Post by mattroessner »

We recently upgraded our test IBM i server to V7R5 and it appears to have broken our ruby applications. We are running a pretty old version of Ruby (2.0.0p598) as far as I know.

I included the errors we are receiving below...

Any help or guidance would be much appreciated

/PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': load failed - /PowerRuby/prV2R1/lib/ruby/2.
1.0/powerpc-aix6.1/openssl.so. Please issue below command for detailed reasons: (LoadError)
/usr/sbin/execerror ruby "(ld 3 1 CRYPTO_add_lock /PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openssl.so" "(ld 3 1 CR
YPTO_set_id_callback /PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openssl.so" "(ld 3 1 CRYPTO_set_locking_callback /PowerRuby/
prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openssl.so" "(ld 3 1 CRYPTO_num_locks /PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openss
l.so" "(ld 3 1 CRYPTO_set_dynlock_destroy_callback /PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openssl.so" "(ld 3 1 CRYPTO_se
t_dynlock_lock_callback /PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openssl.so" "(ld 3 1 CRYPTO_set_dynlock_create_callback /
PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openssl.so" "(ld 3 1 SSLeay_version /PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.
1/openssl.so" "(ld 3 1 HMAC_CTX_cleanup /PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openssl.so" "(ld 3 1 HMAC_CTX_init /Power
Ruby
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/openssl.rb:17:in `<top (required)>'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/PowerRuby1.0.9/prV2R1/lib/ruby/gems/2.1.0/gems/puma-3.3.0-powerpc-aix-6/lib/puma/accept_nonblock.rb:1:in
`<top (required)>'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/PowerRuby1.0.9/prV2R1/lib/ruby/gems/2.1.0/gems/puma-3.3.0-powerpc-aix-6/lib/puma/server.rb:12:in `<top (r
equired)>' from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/PowerRuby1.0.9/prV2R1/lib/ruby/gems/2.1.0/gems/puma-3.3.0-powerpc-aix-6/lib/puma/launcher.rb:1:in `<top
required)>'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/PowerRuby1.0.9/prV2R1/lib/ruby/gems/2.1.0/gems/puma-3.3.0-powerpc-aix-6/lib/puma/cli.rb:4:in `<top (requ
red)>'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/prV2R1/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /PowerRuby/PowerRuby1.0.9/prV2R1/lib/ruby/gems/2.1.0/gems/puma-3.3.0-powerpc-aix-6/bin/puma:6:in `<top (required)>'
from /PowerRuby/PowerRuby1.0.9/prV2R1/bin/puma:23:in `load'
from /PowerRuby/PowerRuby1.0.9/prV2R1/bin/puma:23:in `<main>'
Scott Klement
Site Admin
Posts: 653
Joined: Sun Jul 04, 2021 5:12 am

Re: V7R5 & Ruby

Post by Scott Klement »

I've never used Ruby (on any platform) but the error message says that it can't load /PowerRuby/prV2R1/lib/ruby/2.1.0/powerpc-aix6.1/openssl.so

Have you looked to see if that file exists? If so, is it a symbolic link... and if it's a link, does the file it points to exist?
Post Reply