Get HTTP/1.1 Internal Server Error running HTTPLIB/EXAMPLE18

Discussions related to HTTPAPI (An HTTP Client Package for RPG programming.) http://www.scottklement.com/httpapi/
Post Reply
fellathedog
Posts: 3
Joined: Fri Jul 22, 2022 6:03 pm

Get HTTP/1.1 Internal Server Error running HTTPLIB/EXAMPLE18

Post by fellathedog »

Running HTTPLIB/EXAMPLE18 program with the parameters that are suggested, I get HTTP/1.1 Internal Server Error which from what I see from research is hard to track down as far as the cause. This example is a SOAP 1.2 program. Nothing else I can really supply. Hope somebody has experienced this before and can help, thanks.
fellathedog
Posts: 3
Joined: Fri Jul 22, 2022 6:03 pm

Re: Get HTTP/1.1 Internal Server Error running HTTPLIB/EXAMPLE18

Post by fellathedog »

If this is any help, running EXAMPLE16 fails as well (SOAP 1.1) with HTTP/1.1 405 Not allowed.
Scott Klement
Site Admin
Posts: 257
Joined: Sun Jul 04, 2021 5:12 am

Re: Get HTTP/1.1 Internal Server Error running HTTPLIB/EXAMPLE18

Post by Scott Klement »

These examples use the old WebserviceX.net web site as an example of working with SOAP. I don't think that site is still active -- I think they may have taken it down.

It is still valuable as an EXAMPLE, though -- remember, these were never meant to be used in your programs -- they were meant to TEACH YOU how to use SOAP so you could use it with your own SOAP APIs that you need to call.
fellathedog
Posts: 3
Joined: Fri Jul 22, 2022 6:03 pm

Re: Get HTTP/1.1 Internal Server Error running HTTPLIB/EXAMPLE18

Post by fellathedog »

Thanks, I understand. Just trying to see if I could at least get something running. It is hard to start from nothing and have very few avenues of help. OK pity party over! I do have a real world webservice I need to create, but go back to reason for pity party. I think I am in a loop! :)
Post Reply