DocumentHelper-Illegal recflective access

Scott Klement's open source interface to the POI HSSF/XSSF Spreadsheet Project for RPG Programmers. http://www.scottklement.com/poi/
Post Reply
jtaylor
Posts: 15
Joined: Tue Dec 21, 2021 10:51 pm

DocumentHelper-Illegal recflective access

Post by jtaylor »

I've been seeing this blurb print to our system printer for some time now. Any idea what I need to do to resolve it?

Code: Select all

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective acces by org.apache.poi.util.DocumentHelper to method com.sum.org.apache.xerces.internal.util.SecurityManager.setEntityExpansionLimit(int)
WARNING: Please consider reporting this to the maintainers of org.apache.poi.util.DocumentHelper
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
TIA
jtaylor
Posts: 15
Joined: Tue Dec 21, 2021 10:51 pm

Re: DocumentHelper-Illegal recflective access

Post by jtaylor »

Stackoverfow says to upgrade POI to 4.1.0 or 4.1.2. Will HSSFR4 work with those versions? I tested the latest release of POI, and HSSFR4 didn't work at all.

Thanks
Scott Klement
Site Admin
Posts: 613
Joined: Sun Jul 04, 2021 5:12 am

Re: DocumentHelper-Illegal recflective access

Post by Scott Klement »

Sorry, I have no clue. I haven't used this stuff in over a decade, and neither Java 9 nor POI 4 existed back then.
msddcb
Posts: 21
Joined: Wed Jul 28, 2021 5:12 am

Re: DocumentHelper-Illegal recflective access

Post by msddcb »

The latest version of HSSFR4 supports POI Version 3.14 and earlier.
Later versions of POI will require modification to the service program as some of the parameters have been change to enum.
Cheers, Don
jtaylor
Posts: 15
Joined: Tue Dec 21, 2021 10:51 pm

Re: DocumentHelper-Illegal recflective access

Post by jtaylor »

Thanks guys
Post Reply