Update to V7.5

Discussions related to HTTPAPI (An HTTP Client Package for RPG programming.) http://www.scottklement.com/httpapi/
Post Reply
javimart
Posts: 2
Joined: Wed May 31, 2023 12:08 pm

Update to V7.5

Post by javimart »

Hello !
since an update to V7.5 I get the error
CPF9897 - (GSKit) No hay ninguna suite de cifrado compatible entre los puntos finales TLS

It will be a good try update to last version of HTTPAPI ?
Any one is running this app on V7.5?

Thanks in advance
Javier
stefan@tageson.se
Posts: 15
Joined: Wed Jul 28, 2021 7:55 am
Location: Viken, Sweden
Contact:

Re: Update to V7.5

Post by stefan@tageson.se »

Hi, We've been running httpapi 1.43 on ibm i 7.5 for around 4 months without any problems.
If your issues continues after updating httpapi you may have to enable some older and more unsecure cipher suites to solve your problem.
Scott Klement
Site Admin
Posts: 702
Joined: Sun Jul 04, 2021 5:12 am

Re: Update to V7.5

Post by Scott Klement »

When TLS (SSL) tries to connect, it attempts to negotiate the most secure set of cryptographic ciphers between what the server offers and what the client offers.

In this case, they were unable to find anything they could both agree on. In other words, none of the ciphers supported by the server are available to use on the client.

This is unlikely to be related to HTTPAPI -- but rather is related to the list of TLS versions and cipher suites that you have configured in the system values of your IBM i.
javimart
Posts: 2
Joined: Wed May 31, 2023 12:08 pm

Re: Update to V7.5

Post by javimart »

Thank you!
We appreciate your response. While we don't currently have a solution, we believe we have the correct answer.

The issue lies with the WS being hosted on an outdated server that hasn't been regularly updated. We're currently experimenting with various ciphers to resolve the problem, but we admit our limited experience in this area has made it challenging to find the right one.

Regards from Spain,
Javier
Post Reply