DSPLY Host not found.

Discussions related to FTPAPI (An FTP client package for RPG programming.) http://www.scottklement.com/ftpapi/
Post Reply
Posts: 1
Joined: Mon Nov 22, 2021 5:33 pm

DSPLY Host not found.

Post by Docfxit »

I tried getting Testget.

I'm getting an error saying:
DSPLY Host not found.

I don't know what it means. I don't know what to enter into the reply.

I saw in the source it is trying to connect to:

I tested that server with a different client. I see the tools folder is not there any more.

Does anyone have an update to get this working?
Scott Klement
Site Admin
Posts: 572
Joined: Sun Jul 04, 2021 5:12 am

Re: DSPLY Host not found.

Post by Scott Klement »

FTPAPI has asked your IBM i to tell it the IP address for host 'ftp2.freebsd.org' -- your IBM i has responded saying that it cannot find that host. Therefore 'host not found' is the error message.

I do not get that message on my system. This makes me think that you do not have DNS set up on your IBM i. (Or, perhaps, it is restricting which hosts you can look up.)

I have no idea if that folder is still available -- I haven't used TESTGET in at least 15 years! It worked back then. This is meant as an EXAMPLE, you do not need to connect to FreeBSD.org in order for FTPAPI to work. Presumably you have some other computer that you want to send/receive files to/from?
Post Reply